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Getting Started 
?? Set up a Local Root Folder to house your Web site, and get acquainted with Dreamweaver’s interface, 

palettes, and inspectors. 
?? Create a new document and do basic text formatting, change headline and paragraph formats and align your 

text on a page. 
?? Preview pages in a browser. 

 
 
Building the Site 

?? Create and format more pages and start building a site. 
?? Learn how to import text and reformat it, how to work with images, how to create horizontal rules and lists, 

and how to create hyperlinks between your pages. 
 
 
Creating Tables and Frames 

?? Learn to insert and configure a table and modify it to meet your needs. 
?? Create a frameset to make navigating and viewing a site easier.  

 
Adding Image Maps, Animation and Forms 

?? Create an image map and add links. 
?? Learn to embed multimedia files. 
?? Create and incorporate forms of various kinds. 

 



 
 
 
OBJECTIVES 
By the end of this lesson you will be able to: 
• set up a Local Root folder to house your Web site 
• understand the Dreamweaver interface, palettes, and inspectors 
• create a new document and do basic text formatting 
• change headline and paragraph formats and align your text on a page 
• preview pages in a browser 
 
 
SETTING UP A SITE 
Dreamweaver makes it easy to build a Web site on your local computer and then transfer it to a Web 
server. Before you start creating pages you should establish a home for your site so the program will 
keep track of your files as you add more pages, graphics, and other elements. 
 
Designate a Local Root Folder 
First we’ll open the program and designate a Local Root folder, which will correspond to the root 
directory on the Web server. Your local site will become a “mirror” for the site that is actually online. 
1 . With the program open, select File > Open Site > Edit Sites and click on the New Site button . 
2 . When the Site Information dialog box opens type in “bookstore” for a site name. 
3 . Click on the Browse button (PC) or Choose (Mac) to designate a folder on your hard drive to be the 
Local Root folder for this site. This is the folder where you will store files for this site.  
4 . The remaining options in the dialog box are to establish the connection between your local site and a 
remote server. If you have not yet established a remote server you can leave these options empty 
and go back and fill them in later. 
5 . Click OK. What you see now is a directory of the site. We will return to this view when we explain 
how to upload your files to a remote server, but for now close the window to return to the 
Dreamweaver workspace and let’s build our first page. 
 
 
Setting the Page Properties for Your First Page 
1 . With the page open, right-click your mouse (PC) or Control-click (Mac) to open the Page Properties 
dialog box, or open it by choosing Modify > Page Properties from the menu bar. 
2 . Type a title in the text box. This is the title that will appear in the browser’s Bookmarks or Favorites 
list, so it should be descriptive. Let’s call this page “Mythical Bookstore.” 
3 . Click on the square next to Background Color. When the color palette appears you can select a 
color swatch. The best color for this exercise is white, which is also the default. If you wanted to add 
a background image you would use the Browse button next to Background Image. 
4 . Now select the square next to Text Color and choose a dark color for the text. Note that you can 
choose different colors for Link Color (text that is linked), Visited Links (previously selected by a 
viewer), and Active Links (the color of the link while it is  being selected). You’ll learn more about 
links in the next lesson. 
5 . Click O K, then save your page by selecting File > Save As. Save it as index.htm. This will become 
our “entry page” for the site we are building. 
 

Dreamweaver’s color palette is “Web safe,” and uses six-digit Hexadecimal color 
names. Colors selected will stay true even if the end user’s computer only displays 
256 colors. If you’re not satisfied with the available choices, you can create custom 
colors by clicking on the Painter’s Palette icon in the bottom right of the color palette 
and then creating your own colors in the Color Picker dialog box. When seen on a 
256-color display these will default to the nearest Web-safe color. You can also enter 
a desired color’s “hex” number or color name (e.g., Navy, Maroon, White) directly 
into the window. 
 

 
The Property inspector 
1 . After closing the Page Properties window, click on the page and type the words “Mythical 
Bookstore.” If the Property inspector is not already open, select Window > Properties. 



The Property inspector displays properties for whatever object is selected. 
2 . Highlight the words you typed, and let’s use the menus in the Property inspector to change the 
format and font. Change the format to Heading1 and see how the size and style changes. 
Change the font face from default to “Arial.” Change the font size to “7” and then back to the 
default. Click on the Align Center icon (in the group on the right side of the top row) to center the 
text on the page. 
3 . Place the cursor after the headline, and hit Enter (PC) or Return (Mac) and then type your address. 
Highlight the new line, and change the font size to “5.” Change the font color by clicking on the gray 
box below the text size window. Note that color changes made in the Property inspector apply only 
to the item selected, not the entire page. Leave the window open. We’ll look at more options later. 
 
 
 
The Object palette 
1 . Select Window > Objects to open the Object palette. This tool contains buttons for inserting various types of 
objects, such as images, tables, layers, applets, and other multimedia elements. Holding the cursor over each icon on 
the palette will open a caption box explaining the function of each button. 
2 . Now let’s insert a picture between your headline and address. Place your cursor just after the headline and hit 
Enter (PC) or Return (Mac) to open up a space. 
3 . Click on the top button on the Object Palette to choose an image, and browse to the folder “images” inside your 
new Local Root folder (“bookstore”). Click on the jpeg file called books.jpg, and click select then click OK. The 
picture should appear just below your headline. 
4 . Place your cursor next to the image without selecting it, and then click on the Align Right icon in the Property 
inspector and it will move to the right side of the page. Now click on the Align Left icon, then use the A l i g n C e n 
t e r icon to move it back to the middle of the page. 
5 . Click on the picture, and note that the Property inspector automatically changes to show you the image properties 
including its dimensions and location. (Note that the Align option here is for aligning a picture next to a block of 
text, not aligning it on the page. Ignore it for now. We’ll cover this in the next lesson.) 
6 . If you don’t like your color combination, change your choices in the Page Properties window or the text Property 
inspector. 
7 . Remember to save your changes. 
 
 
The HTML Inspector 
Open the HTML inspector by clicking on the H T M L button of the Launcher and you see the H T M L source code 
the program has generated for the page you are working on. Source code containing HTML tags lies behind every 
HTML page, with code e l e m e n t s set off in brackets as in this example, where < H 1 > is similar to Heading1 in 
a word processor. 
Elements are instructions that tell the browser how to display the page. Note that each set of instructions requires a 
beginning and ending tag. The align=”CENTER” statement is an example of an attribute; it modifies the element to 
which it was added. All the user actually sees are the words “Mythical Bookstore.” 
If you are new to HTML, you should spend some time studying the code for the tags you create so you understand 
them and can edit the code directly when necessary. There are now many good books available to help you learn 
HTML. 
Dreamweaver lets you have both the document window and the HTML inspector open at the same time so you can 
see changes in both views. When you highlight text in the document window, it is also highlighted in the HTML 
inspector. 
Note that you can access the HTML inspector in four different ways: from the Launcher, from the F10 hotkey, from 
a button on the bottom of the document window, or from the menu bar (Window > HTML). 
 
 
 
PREVIEWING YOUR WORK IN A WEB BROWSER 
It’s wise to test your work in a variety of browsers to make sure your pages will look good to everyone who sees it. 
 
Setting up a Preview Browser 
Dreamweaver makes it easy for you to set up preview links to different browsers. It’s a preference setting you can 
access from either the Edit > Preferences menu, or from File > Preview in Browser > Edit Browser List. 
1 . Choose Edit > Preferences and look over the various Preference topics. You may want to change some of the 
settings later. Pick Preview in Browser, and click Add. 



2 . Type the name of a browser (such as Netscape or Internet Explorer) in the Name text box, then click the Browse 
button to open the Select Browser dialog box and locate the browser you want to configure. 
3 . Double-click on the program file for the browser, and click Open, then OK. The browser has now been added to 
the list in the Preview in Browser options. You can add other browsers in the same way, and designate one of them 
as your primary browser. 
4 . Now let’s preview our page using Dreamweaver’s F12 hotkey to instantly open the page in the primary browser. 
Compare it to the page as it appears in your Document window and the HTML inspector. 
Later we’ll learn how Dreamweaver can also test your documents in various browsers “virtually” without a visual 
preview, and give you a report on any problems or deficiencies. You can access this useful feature from  
File > Check Target Browsers. 
 
 
 
OBJECTIVES 
In this part of the lesson you will learn: 
• how to import text and reformat it 
• more text and image tags and attributes  
• how to create horizontal rules and lists 
• how to create hyperlinks between your pages and start building a site 
 
 
MORE FORMAT OPTIONS 
Create Another Page and Import Text  
1 . With index.htm open in Dreamweaver, choose File > New Window. This opens up a new page in a new window, 
so you can have both pages open at the same time. You can use the Window menu to toggle back and forth between 
two or more active files.  
2 . Repeat the procedures for setting the page properties.(or copy and paste the HTML code if you know how). Give 
this page the title “On The Coffeetable,” and save it as coftable.htm. 
3 . Now let’s copy some text from an existing text file into your new page. Minimize or hide both 
Dreamweaver windows and find the text file called books.txt in the “Bookstore” folder.  
4 . Open books.txt in any text editor, such as SimpleText, Notepad, MS Word, or WordPerfect, and highlight and 
copy the text. 
5 . Switch back to the new Dreamweaver document window, and click on it, then choose Edit > Paste and paste in 
the text. The text from books.txt now appears on your Web page. Note that it has lost all its formatting, including 
paragraph returns. 
 
Format the New Text  
1 . Click to place your cursor right after the words “On the coffeetable” and press the Enter key (Windows) or the 
Return key (Mac) to insert a paragraph break. Do it again between “our sleeves” and “This month’s specials,” and 
between “This month’s specials” and “The Arica Conundrum”; “cold war” and “Heal Your Cat”; “kittikat cards” 
and “Varoom”; and “kitsch” and “Our catalog.”  
2 . Highlight the words “On The Coffeetable.” In the Property inspector, choose the Heading2 option from the 
Format pull-down menu. 
Use the Align Center icon to align it in the center of the page. Choose the Arial, Helvetica, sans-serif option from 
the Font pull-down menu. 
3 . Now deselect “On The Coffeetable” and highlight “This Month’s Specials.” Leave it left aligned (the default) but 
change the font to Arial, Helvetica, or sans-serif and the format to Heading3. 
4 . Deselect “This Month’s Specials” and highlight all the text below it down through “Dated kitsch.” 
5 . In the Size pull-down menu, choose 2. 
 
 
 
Line and Paragraph Breaks 
We’ve already learned to insert a paragraph tag by hitting the Enter key (PC) or Return key (Mac). This gives you a 
double space break. When you only want a single line break use a line break i n s t e a d . 
1 . Copy the words “The Arica Conundrum” and paste them in front of the words you copied (with a space in-
between) so that the line begins “The Arica Conundrum The Arica Conundrum.” 
2 . Insert your cursor after the first “Conundrum” and press Shift+Enter (PC) or Shift+Return (Mac). Highlight the 
first “The Arica Conundrum” and click on the B (for Bold) button in the Property inspector. 



3 . Repeat the same action with “Heal Your Cat, Heal Your Life,” and “Varoom.” You can also insert a break tag by 
choosing Insert > Line Break or by clicking the Insert Line Break icon in the Invisibles section of the Object palette. 
The default HTML text size is the equivalent of HTML size 3, so in Dreamweaver’s Size pull-down menu, 3 is the 
equivalent of Normal text on the Web, 1 and 2 are smaller, and 4 and up are larger. You can also use positive and 
negative numbers to increase or decrease the default size incrementally. 
 
Add a Horizontal Rule 
The Horizontal Rule tag creates a line that spans the width of a Web page. By changing the tag’s attributes, you can 
alter the thickness of the rule and limit its span to only a portion of the page. 
1 . First let’s copy and paste the words “Our Catalog” as we did in the last exercise so the phrase repeats itself. This 
time insert a paragraph break between them, highlight the first occurrence, and format it as a Heading3. Change the 
font to Arial, Helvetica, or Sans Serif. 
2 . Now click on the space just before the headline, “Our catalog” then click on the HR button on the objects palette 
(or choose Insert > Horizontal Rule from the menu bar at the top of the page). 
3 . Use the Property inspector to change the width to 75% and the alignment to center. (You have your choice of 
pixels or a percentage of page width.) 
4 . Now click after the line that begins “Our catalog...” and following the same steps, add another horizontal rule. 
 
CREATING LISTS 
Dreamweaver makes it easy to create ordered lists (set off by numbers or letters), unordered lists (preceded by 
bullets), and definition lists (indented but not preceded by numbers or bullets). You can create lists as you type text 
into a document, or you can highlight existing text and apply the list format. Lists can also be nested to create 
outlines and other more complicated lists within lists. 
To Create a New List 
1 . Position the cursor after “parade of the desperate” and add a paragraph break. 
2 . Click the Numb ered List button in the Property inspector (or choose Text > Format and select ordered list) . 
3 . Enter the items list, pressing Enter (PC) or Return (Mac) for each new list item. Make the items “Lovedogs,” 
“Spacebopping,” and “Purp L. Elephant.” 
4 . Press Enter twice to complete the list. 
 
Creating a List from Existing Text  
1 . Select all the text between “This Month’s Specials” and the first horizontal rule. 
2 . Click on the bullet list button in the Property inspector (or select Text > Format > unordered list from the menu 
bar). A bullet will appear before every bold line. Every text block surrounded by paragraph tags is turned into a 
separate list item. 
 
Indenting Text  
The definition list format can be used to make lists without bullets or numbers. It can also be used to indent 
paragraphs and text blocks. 
1 . Select the text between the headline “On the Coffeetable” and “This Month’s Specials” and click the Text Indent 
icon in the Property inspector. Dreamweaver creates indents at the left and right of the block. 
 
 
 
 
 
 
 
 
 
 
IMAGE FORMAT OPTIONS 
OBJECTIVES 
By the end of this part of the lesson you will be able to: 
• position images and text together 
• wrap text around an image 
• add horizontal and vertical spacing around an image 
 
1 . With the file coftable.htm open, place your cursor to the left of the headline “On the Coffeetable.” Do not insert a 
paragraph break. 



2 . Click the top button on the objects tool, or choose Insert > Image from the menu bar. Browse to find books2.jpg 
in the “images” folder in the “bookstore” folder and double-click to select it. Click OK. 
3 . Select the picture so the Image Property inspector will open. In the A l i g n pull-down menu select Absolute 
Middle. 
4 . Type the words “books” in the Alt text box on the Property inspector. Save your work, but don’t close the page. 
Wrapping Text Around a Picture 
1 . Select File > Open and open arica.htm, located in the “catalog” folder inside the “bookstore” folder. Set page 
properties as before, and then position your cursor to the left of the book title, The Arica Conundrum. 
2 . Click on the Object palette as before to insert an image, browsing to locate an image called arica.gif in the 
“images” folder inside the “bookstore” folder. 
3 . Click on the image so the image properties are displayed. Now click on the Align pull-down menu at the top right 
of the Property inspector and choose Left. Note that the image aligns to the left of the page, and the text aligns to the 
right of the image. 
4 . Type the name of the book, Arica Conundrum in the A l t text box on the Property inspector. 
5 . In the H Space text box in the bottom left of the Property inspector, enter the number “10.” This places 10 pixels 
of horizontal space on either side of the image, separating it from the text that appears on the right. Use the V Space 
text box if you want to add vertical space. 
Your image is now aligned to the left of the page, with the text wrapped around the right of it. If you align the image 
to the right, the text moves to the left of the image. 
6 . Repeat steps 1-5, but this time open the file called varoom.htm and use the picture varoom.jpg. Save your 
changes. 



SETTING HYPERLINKS 
OBJECTIVES 
In this part of the lesson you will learn: 
• how hyperlinks work 
• when to use absolute versus relative links 
• how to link text or images to other files within your site 
• how to create an internal (or jump) link from one place in a file to another 
• how to link to a page in another site 
 
 
About Link Paths 
You have three options when you set links in HTML—an absolute path, a document-relative path, or a site-root-
relative path. The default path in Dreamweaver is relative to the document. 
 
An absolute path is a link to a complete address, such as: 
h t t p : / / w w w . m a c r o m e d i a . c o m / s o f t w a r e / 0 0 _ s o f t w a r e . h t m l 
You must use an absolute path when you link to a page on another Web site, but should avoid using the full address 
to link to pages within the same site. 
 
Document-relative paths are relative to the directory containing the current document. For example, books.htm 
specifies another document in the same folder/directory; best/books.htm specifies a document in a folder inside of 
the current folder, named best; and ../books.htm specifies a document one level above the current directory. 
Site-root-relative paths always begin with a forward slash, indicating the site root (or top-level directory) of the 
server. All visible files branch from the site root. The path /books/index.html links to a document named index.html 
in the books directory, which is at the root level (or top level) of the site. 
 
This is a good way to link files in a Web development environment where content must be moved frequently. The 
links continue to work even if the document is moved within the site (but not if the linked files are moved). To make 
the link relative to the Site Root, use the pull-down menu at the bottom of the Select HTML dialog box that opens 
when you click on the Link Folder in the Property inspector. 
 
Be aware that browsers don’t recognize a site-root when opening a local file. To preview content you will 
have to set up a local server and use the Preview Online option (Windows only), or put the file on a 
remote server. 
 
Create a Link from One Page to Another with Text  
1 . With the file coftable.htm open, scroll down to the first line under the headline “This month’s specials.” Select 
the words “The Arica Conundrum.” 
2 . In the Property inspector, click on the Folder icon to the right of the Link text area. Browse to find arica.htm in 
the “catalog” folder and double-click to set it. The text changes to the link color chosen previously in the Page 
Properties dialog box. (Blue is the default.) 
3 . Repeat the same steps with the words “Varoom,” linking it to varoom.htm. 
4 . Save your work and preview it in a browser, clicking on the new link and then back. 
 
Create a Link to Another Page from an Image 
1 . Linking from an image works exactly the same way as linking from text. Open or switch to index.htm, and select 
the image books.jpg. Click on the “Link” folder in the Property inspector, and browse to find the file coftable.htm in 
the same folder. 
2 . Remove the colored border that appears around the image when you make it a hyperlink, selecting the image and 
setting B o r d e r to “0” in the Property inspector. 
3 . Save your work and preview it in a browser, clicking on the new link and then back. 



 
Setting Internal Links 
To create an internal link (also called a jump link) from one part of a page to another or from one page 
to a specific location on another page, you must first place an a n c h o r in the place you want to link to. 
This is particularly helpful for long pages. 
1 . Switch to the page coftable.htm and place the cursor to the left of the headline “This month’s specials . ” 
2 . Choose Insert > Named Anchor from the menu bar (or click on the top button in the “Invisibles” section of the 
Object tool, which you can access by using the scroll arrow at the top of the tool.) 
3 . When the Named Anchor dialog box appears, enter the name “specials” to represent this location on the page, 
and click OK. It’s a good idea to choose a name you will remember when you set the link to this location. 
If View > Invisibles is checked Dreamweaver displays a small icon that looks like an anchor. It won’t 
be visible when the page is displayed in a browser. 
 
Create a Link on Another Page that will take Visitors to an Anchor 
1 . Open or switch to the arica.htm page in the “catalog” folder and insert your cursor to the right of the price of the 
book. 
2 . Press the Enter key (PC) or Return key (Mac) to insert a paragraph break, and type in the words “This month’s 
specials.” 
3 . Select the words “This month’s specials” and use the Property inspector Link icon to browse to the coftable.htm 
file. 
4 . Now click in the text box, just to the right of the coftable.htm filename, and type “#specials”. The # followed by 
the anchor name specifies that the link should go directly to the anchor. 
If you wanted to link to a Named Anchor called “specials” on the same page where the link originated, you would 
type “#specials” in the Link Text area of the Property inspector without specifying the file name. 
5 . Making sure you are still on the document window for arica.htm, save the page, and press F12 to preview your 
links in a browser (or select File > Preview in Browser). Click on the link to test it. 
 
Linking to Other Web Sites 
Dreamweaver makes is easy to set a link to another Web site—all you need to do is type in the 
complete URL in the Link box in the Property inspector. 
 
 



BUILDING AND USING TABLES 
OBJECTIVES 
In this part of the lesson you will learn: 
• the value of tables in positioning design elements on a page 
• how to insert and configure a table and modify it to meet your needs 
 
Tables are an integral part of many good designs on the Web. You can insert any image, text, or multimedia file in a 
table cell, which will help you position it on the page. By merging and dividing the cells and then hiding the borders 
you can create complex designs. 
Tables are especially useful when you want to arrange images or text side-by-side on a page or stagger pictures and 
text. You can use them to create columns like those in a newspaper or magazine, or more open designs with 
elements distributed around the page. 
 
Control Your Page Layout by Arranging Images in a Table 
In this exercise you’ll use a table to position images of different sizes so they appear side-by-side on a page, merging 
cells to accommodate images of different sizes. 
1 . Open the file garden.htm (in the “garden” folder, inside the “bookstore” folder). The page includes five images: 
four small images—an apple, an artichoke, a carrot, and an eggplant—and a large image of a pumpkin. 
2 . Click to insert your cursor at the top left of the page, just to the left of the apple, and insert the headline “Garden 
Emporium.” Use the Property inspector to center the headline and format it as a Heading2. Now choose Insert > 
Line Break and type the words, “Check out our specials.” Hit Enter (PC) or Return (Mac) to enter a paragraph break. 
3 , Again insert your cursor to the left of the apple, then click the T a b l e icon in the Object palette or choose  
Insert > Table from the menu bar. 
4 . When the Insert Table dialog box appears, enter “4” in the Rows field and “2” in the Columns field and set the 
Width to “80” percent. Then Click OK. 
When you choose a percentage, the table will adjust to the viewer’s window size. This works well if you want your 
table to fill a certain percentage of the screen no matter what size your viewer’s browser window or monitor is. If 
you want better design control, select pixels rather than percent to create a fixed-width table to ensure that the 
elements you arrange in the table cells do not shift around when the table adjusts. 
5 . Select the pumpkin image and drag it to the top left cell of the table. 
6 . Select the apple image and drag it to the top right cell of the table. 
7 . Select the artichoke image and drag it to the second cell on the right. 
8 . Select the carrot image and drag it to the third cell on the right. 
9 . Select the eggplant image and drag it to the fourth (and bottom) cell on the right. 
10 . Drag your cursor across the entire table (or click on the outside border) to select it, then use the Align pull down 
menu in the table Property inspector to center it on the page. 
 
Adjust Spacing by Merging Cells  
1. Click to insert your cursor anywhere in the cell that contains the pumpkin. (But don’t select the image itself.) 
2 . In the Property inspector, click the Increase Row Span button (Figure 4-1). This will cause the cell with the 
pumpkin in it to merge with the empty cell below it. 
3. Click the Increase Row Span button two more times to merge all of the cells on the left of the table into one. 
Merging the cells on the left moves the cells on the right up so the smaller images appear just to the right of the 
pumpkin.  
4. Click on the cell border that separates the pumpkin from the other fruit and vegetables. Your cursor should turn 
into a tiny line with arrows at both ends. Use it to drag the border to the left so it is closer to the pumpkin. 
5 . Click inside the cell with the apple (but not on the image). Now choose Modify > Table > Cell Properties from 
the menu bar and change the horizontal alignment to center. Do the same with the cells containing the artichoke, 
carrot, and eggplant. Note that you can also select cell properties with a mouse right click (PC) or Control click 
(Mac) inside the cell. 
6. Click on the outside border of the table to select the entire table. 
7 . In the Property inspector, set the Table Border to “0.” Setting the border to 0 makes the table itself invisible when 
viewed in a browser. 
8 . Save your work and use the F12 key to preview it in a browser. 
9 . Open the file coftable.htm, highlight the words “garden emporium” in the first paragraph and use the Property 
inspector to create a link to garden.htm. 
 
 
 
 



BUILDING AND USING FRAMES 
OBJECTIVES 
In this part of the lesson you will learn: 
• how to use frames to make navigating and viewing your site easier 
• how to set up a frameset, specify the size of the panes, set links, and provide alternate content 
 
Using Frames you can split a browser window into multiple windows. Each window can be controlled separately, 
making it possible to keep some the contents of one window constant on a page while other features change. It’s a 
useful way to establish a fixed navigation bar. You can place the links in one frame and specify that the pages they 
link to are displayed in another frame in the same browser window. 
 
A frameset establishes which HTML pages will fill each frame when they are displayed in a browser. When you 
create a Web page that uses frames, you actually create multiple pages, because each frame in the frameset is a 
separate HTML file. The frameset describes the size and location of each of the frames, along with the names of the 
HTML files displayed in each frame. Thus, a Web page with two frames is actually three separate files: the frameset 
file and two files containing the content that appears inside the frames. 
Because each frame is just another HTML file, you can insert text, images, multimedia files, tables, and any other 
elements in each Frame. Dreamweaver displays all of the pages in the frameset simultaneously so you can see how 
the page will be displayed in a browser. To edit each page, just move your cursor from one frame area to another 
and format it as you would any other HTML file. 
To save the HTML displayed within a frame, place your cursor in the frame area and choose File > Save. To save a 
frameset file, choose File > Save Frameset or File > Save Frameset As. To save all open files at once, choose File > 
Save All. The Save All feature saves the frameset as well as all of the displayed HTML pages. You are prompted to 
name each file as it is saved. 
 
Create a Frameset with Three Frames 
1 . Choose File > New to create a new page. Set the page properties as before (Modify > Page Properties) and give it 
the title, “Garden Emporium.” 
2 . Choose View > Frame borders. A thin outline will appear on the top and left of your document window. Position 
your cursor on the top outline and hold down the Alt key (PC) or the Option key (Mac). Click, hold and drag the 
frame border down. 
The page is divided in half and a frame border appears horizontally across the middle. The top and bottom sections 
of the window are now two different HTML pages. A third HTML page, the frameset, describes the location and 
size of the first two. 
3 . While holding down the Alt (PC) or Option+shift keys (Mac), click to place your cursor in the bottom frame area 
4 . Select the outline on the left side of the page and drag out a frame as above, by using your mouse. The page is 
now divided into three sections. 
5 . Click to select the bar that divides the top and bottom sections of the page. Drag the bar until the top frame only 
covers about a fourth of the entire page. 
6 . Now click to select the bar that divides the left and right sections of the lower frame. Drag the bar to the left until 
the left frame only covers about a fourth of the available space. 
 
Edit each Section of the Frameset 
Remember that we are actually creating four separate HTML documents: the frameset, the top frame, the left frame, 
and the right frame. We can edit each section of the frameset as we would any other Web page. 
1 Choose File > Save Frameset, and call it foodset.htm. 
2 . Click on the top frame and save the document as top.htm in the “garden” folder. Now use the Object palette to 
find and insert an image called banner.gif, which is inside the “images” folder. Center it on the page, and adjust the 
frame border as necessary to display it properly. (Click outside the image to open the right Property inspector, then 
use the center icon). Save your work. 
3 . Click on the left frame and save the document as left.htm. Type in the words “Fresh Fruit and Veggies!” and use 
the Property inspector to format it as Heading2. Now add a line break between “fruit” and “and.” 
4 . Insert a paragraph break after “veggies,” then use the Object palette to find and insert the image pumpkin.gif. 
5 . Insert another paragraph break, then find and insert the image apple.gif. Do the same thing again, adding 
eggplant.gif. 
6 . Click on the line separating the two lower frames and drag it to the left until the text and images are.  
7 . Click on the large empty frame and type in the words: “Choose any food on the left to see today’s special prices.” 
Format it as Heading2. Save the frame as display.htm. 
8 . Choose File > Save All, which will save any changes to all four documents . 
 



Setting Links in a Frameset 
Links in frames are essentially the same as links in any other HTML file, except that in a frameset you must specify 
a t a r g e t to identify where the linked page will open. When you have a row of links in the left frame on a page and 
want them to open in the right frame, the right frame becomes the target. Before you can link to a target, you have to 
name it. The following exercise will show you how to create a link in a frame that changes the content of a different 
frame: 
1 . Use Alt + click (PC) or Option + shift + click (Mac) and select the right frame (or choose Window > Frames 
from the menu and select the right frame in the Frames inspector) . 
2 . If the Property inspector is not already open, choose Window > Properties. Name the frame by entering “display” 
in the Frame text box (just under the word Frame) in the Property inspector. (You could call it anything.) 
3 . Repeat step 2 and enter a name for each frame in the frameset. For simplicity name them “top” and “left.” Note 
the other frame properties you can also set here, which control other attributes like scrollbars, margins, and color. 
4 . Highlight the image of the pumpkin in the left frame, and click on the Folder icon next to the Link text box in the 
Property inspector. 
6 . Browse to locate the file pumpkin.htm (which you will find in the “links” folder inside the “garden” folder). 
Double-click on the filename to select it. The filename and path automatically appear in the Link text field. 
7 . If it’s not open, click the expander arrow in the lower right corner of the Property inspector. From the Target pop-
up list, choose “display” as the name of the frame into which you want the linked page to open. Set the border to 0.” 
8 . Repeat steps 4 through 7 for the apple and eggplant. Again choose “display” from the Target pop-up list as the 
name of the frame into which you want the linked page to open. 
9 . Choose File > Save All to save your work, and use the F12 key to test your layout and links in a browser. 
10 . Now open the file garden.htm, highlight the words, “check out our specials” and use the Property inspector to 
make a link to foodset.htm. Checking the HTML Code in the HTML Inspector 
Remember there are actually four documents in play here. To see the HTML code for any individual frame just click 
on that frame and use the F10 hotkey or the HTML button on the Launcher. Inspecting or editing the code for the 
frameset document is a little more tricky. Choose Window > Frames from the menu bar. The Frames inspector will 
open showing you the outline of the frameset. Click on the open window, then open the HTML Inspector. 
 
Designing Frames for Older Browsers 
Unless you provide an alternative page, older browsers that do not support frames will display a blank page. To 
prevent this, use the Noframes option, which enables you to provide an alternative page to be displayed only by 
browsers that don’t support frames. 
To create a simple alternative page, using the noframes option: 
1 . Choose Modify > Frameset > Edit Noframes Content. Dreamweaver clears the Document window and the words 
“noframes content” appear at the top. 
2 . Enter your Noframes content in the Document window, adding images, text, and other elements to the page and 
formatting them the same way you would any other document. 
3 . Choose Modify > Frames > Edit Noframes Content again to return to the normal view of the frameset document. 
You can use the HTML Inspector to view the source of the Noframes page in the Frameset document. The Noframes 
section will begin and end with <noframes> tags. Inside it will look like the <body> section of the page that is not 
contained in a frame. 
 
ADDING IMAGE MAPS, ANIMATION, AND FORMS 
CREATING AN IMAGE MAP 
OBJECTIVES 
By the end of this part of the lesson you will: 
• understand how image maps can enhance a design and make a site more interactive 
• know how to create an image map easily with Dreamweaver 
 
An image map is simply an image with multiple “hotspots” or links. It works on a grid principle, with coordinates 
telling the browser that a defined section of the image should link to a particular URL. Dreamweaver makes it easy 
to graphically create and edit client-side image maps by providing an Image Map Editor. 
 
Create an Image Map 
1 . Open the document coftable.htm, and select the image of the books at the top of the page. 
2 . In the Property inspector you will find a M a p button. Click on it to open the Image Map Editor dialog box. 
3 . Enter “Map1” as the map name at the top of the window so your image map changes will be saved as you work. 
4 . Note the four tools at the left side of the Image Map Editor. The arrow at the top is a selection tool you can use to 
move hot spots around the page or to resize them. The other three options are drawing tools you can use to define 
hot spots with different shapes. 



Select the rectangle tool, and click and drag to create a rectangular shape covering the outline of the book Varoom. 
The mapped area will then be highlighted. 
5. To create the link, click on the Folder icon next to the Link text field, and browse to find varoom.htm in the 
“catalog” folder. Double-click to select it. In the Alt text field enter the word “varoom.” 
6 . Select the Polygon tool—the bottom one in the row. This tool enables you to create odd-shaped hot spots. Click 
on one corner of the “The Arica Conundrum” book cover, then move your cursor to the next corner and click. 
Continue until you have clicked all the way around the book. Double-click to complete the action. Don’t worry 
about the shape overlapping the varoom rectangle. The one on top takes precedence. 
7 . Repeat step 4 to link the new hot spot to the file called arica.htm. Enter “arica conundrum” in the Alt text field. 
8 . Repeat the same process with the book cover “Heal Your Cat, Heal Your Life.” 
9. Click OK to close the dialog box. 
10 . Select File > Preview in Browser and choose a browser to view the page. Test the links to see how the hot spots 
work. Note that there is now a border around the image. If you want to remove it return to the Property inspector and 
enter “0” in the Border text box. 
11 . Be sure to save your changes. 
 
ADDING MULTIMEDIA FILES 
OBJECTIVES 
In this part of the lesson you will learn: 
• how to use Dreamweaver to add sophisticated multimedia effects to Web sites 
 
Web builders now have a rich variety of multimedia options—from animated interactivity to streaming sound. You 
can use Macromedia Director or Flash, for example, to create interactive Shockwave movies, and Aftershock to 
enhance functionality. Dreamweaver makes it easy to add these files to your Web pages and make sure they work 
well in as many browsers as possible. Keep in mind that many multimedia files require a plug-in, which extends the 
capabilities of your browser. You will need to have the proper plug-in installed, when you test your work in a 
browser, or you won’t be able to see the effect. You can get the Shockwave plug-ins from www.macromedia.com. 
 
To insert a Flash File into your Web Page 
1 . Choose File > Open and browse in the “bookstore” folder to the “catalog” folder and then open catalog . h t m . 
2 . Set the Page Properties (Modify > Page Properties) any way you want and click OK. 
3 . In the Document window, highlight the line of text at the top of the page (beginning “Here is the complete...”) 
and use the Property inspector to italicize it. Save the page. 
 
4 . Now position your cursor in front of the words “Everyday Epiphanies,” then open the Object 
palette, and click on the Insert Flash Movie icon. 
5 . When the Insert Flash Movie dialog box opens, Use the Browse button to locate the file crazybird.swf in the 
“bookstore” folder. The .swf stands for Shockwave Flash. Every multimedia file type has its own extension. Double-
click the file to select it, then click OK. 
6 . A small icon now appears on the Web page, representing the Flash movie. 
7 . Click on the movie. The Property inspector now displays the options for Flash attributes. 
8 . Enter “300” in the Width field (indicated by W) and “250” in the Height field (indicated by H). Note how the size 
of the gray box representing the movie expands. Height and width are the only required attributes for most 
multimedia file types. Flash is unique in its capability to resize itself without losing quality, which means you can 
set the height and width of the movie to anything you want. 
9 . In the tag field Dreamweaver uses both Object and Embed tags. (Object is the tag defined by Microsoft for 
ActiveX controls; Embed is the tag defined by Netscape for plug-ins.) To learn more about other attributes, refer to 
the Dreamweaver online Help files. 
10 . Insert a paragraph break before the words “Everyday Epiphanies,” save the page, and choose File > Preview in 
Browser. Select a browser that has the Flash plug-in installed.  
 
Make a Link to the Page 
Now open or switch to coftable.htm and scroll down until you see the words “Our catalog...”. Highlight “catalog” 
and use the property inspector to link it to catalog.htm (which is inside the folder “catalog”). Now highlight the word 
“Lovedogs” and make a link to the same place. Do the same with “Spacebopping” and “Purp L. Elephant.” Preview 
the page, test the links, then save it. 
 
 
 
 



BUILDING FORMS 
OBJECTIVES 
In this part of the lesson you will learn: 
• how to create various forms and what you can do with them 
• how to use CGI scripts and “mailto:” to collect information from forms  
 
Dreamweaver can create a variety of forms you can use to capture information of all kinds from the visitors to your 
site. You can conduct a survey, collect customer contact information, or put a guest book on your Web site with 
fields for visitors’ names, addresses, interests, comments, and questions they might want to ask. When the visitor 
has filled out the form they click on the S u b m i t button to send it to you. 
You’ll need to provide a mechanism for the visitor’s computer to send you the information they have entered into 
the form. Most often this is done using a CGI script, a program that will process the submission of the information 
and then send it to you via email, or post it dynamically to a page on your Web site. 
CGI or Common Gateway Interface scripts are programs, usually written in a programming language such as Perl, 
Java, C, or C++. CGI scripts are the engines behind many HTML forms and other dynamic features on a Web site. 
To create a CGI script you’ll have to know how to program or hire a programmer to do it for you. You can also find 
and modify existing scripts. But to keep it simple, we’re going to use a less sophisticated but much simpler method 
of sending information from a form back to your server using a simple m a i l t o : t a g . The mailto: tag does not 
work in all browsers, and the results are not as user friendly as a CGI script. You will receive a text file as an email 
attachment which you can open in any text editor to interpret the results. One way to process it is to import the text  
into a spreadsheet program like Excel as an ASCII delimited dataset. For an example of a CGI form visit 
http://www.best.com/~mbrown/cast74g/lessons/lesson3 
 
EXERCISES 
Creating an HTML Form 
Dreamweaver’s Object palette has a series of insert buttons for a variety of different forms. Let’s look at some of 
them. 
1 . With coftable.htm open, scroll to the bottom of the page, click your cursor after the second horizontal rule, and 
insert a paragraph break. 
2 . If the Object palette is not already open, choose Windows > Objects from the menu bar to open it. 
3 . Now use the scroll arrow at the top of the palette to access the F o r m s group. Hold your mouse over each of the 
the six buttons on the Object palette long enough to see it’s name appear. 
4. Click on the top button in the group to insert a blank form space. 
A blank form in Dreamweaver is represented by a rectangle outlined by a dotted red line.Selecting this rectangle 
reveals the Form properties in the Property inspector. 
5 . Enter the name “survey” in the text box under the word “Form.” This name is used by scripting languages such 
as JavaScript or VBScript to control the form. 
6 . In the text area next to the word “Action” put the directory name and name of the script used to control the form. 
We’ll keep it simple by using a client side “Mailto.” Just enter your email address thus: 
“mailto:you@yourweb.com.” Set the method to “Post.” 
7 . Now, click to insert your cursor within the form area on the page, and type the following questions separated by a 
return: 
What is your name? 
What is your email address? 
What is your favorite book? 
Which is your favorite food? 
8. Click to place your cursor after the first question and click on the button for Insert Text field, which is the second 
button from the top on the Object palette. (You can also use Insert > Form Object > Text Field on the menu bar.) 
A small bounded rectangle appears immediately after the question. In the Property inspector type “Name” into the 
TextField box and set Char Width (character width) to “50.” The text box immediately expands. Naming the field 
has no obvious effect, but it will be used by the CGI script or Mailto: to identify the contents of the field when data 
is submitted. 
 
9 . Enter “None of your business” in the Init Val field. The Init Val field is an initial value that will display in a text 
field unless a viewer chooses to delete or overwrite it. In most cases this will be left blank. 
10 . Insert another text field after the second question. Name it “email” and give it a Char Width of “40.” 
11 . Insert another text field after the third question. Call it “book” and make Char Width “40.” 
12 . Place your cursor after the fourth question, but this time choose the 6th button from the top, Insert List/Menu. 
(Or use the menu bar to select Form Object > List/Menu. ) 



13 . Type the name “Food” into the List/Menu field, set the Type radio button to Menu, and click the List Value 
button . The List Values dialog box appears. 
14 . In both the Item label and Values columns,type “pumpkin.” 
15 . Click the + symbol to add a new line, and type “carrot” in both columns. 
Following the same process enter “artichoke,” “apple,” and “eggplant”. 
16 . Enter a paragraph break by placing your cursor just after the last text field and pressing Enter (PC) or Return 
(Mac). 
17 . Click on the third button from the top in the Object palette, Insert Button (or choose Form Objects > Insert 
Button from the menu bar). 
18 . Repeat the operation so you have two identical buttons next to each other. 
19 . Now let’s change the first button to make it reset the form. Select the first button. In the Property inspector, 
check the radio button that says “Reset form.” Note that the label and button name change as well. 
20 . Preview and test your form by filling in your name, changing the text in the second text field, and picking a 
food from the pull down menu you just created. 
 
Adding Radio Buttons 
Radio buttons allow viewers to select from multiple choices. Only one button in a group is active at one time. We’re 
going to add some radio buttons to our form. 
1 . After the email address field, type the question “Where are you from?” Click your cursor in the form right after 
the question. 
2 . Click the Insert Radio Button icon on the Forms panel of the Object palette, or choose Insert >Form Object > 
Radio Button. 
3 . Repeat this step three times so there are four buttons. To the right of the first one type “East,” to the right of each 
of the others, “West,” “North,” and “South.” 
4 . Click to select one of the radio buttons and reveal the Radio Button properties in the Property inspector. All radio 
buttons in a group should have the same name. Let’s just go with the default name for the text area under Radio 
Button. 
6 . Now do the same with the other buttons. Each should have a different Checked Value name so the CGI script can 
distinguish them. We’ll give each button’s Checked Value the same name as the button itself so it will be easy to 
keep track: “East,” “West,” “North,” and “South.” 
 
Adding Checkboxes 
Checkboxes enable viewers to make multiple choices, so they are good for choices that include such  
instructions as “Choose all that apply.“ 
1 . Click to insert your cursor after the new radio buttons and hit Enter (PC) or Return (Mac) to insert a paragraph 
break. 
2 . Choose the Insert Checkbox icon on the Objects palette, or Insert > Form Object > Checkbox from the menu bar. 
After the checkbox type “Check if you want be on our email list.” 
3 . Insert another checkbox and type “Check if you want us to share your name with other companies.” 
4 . In the Property inspector for each checkbox enter a name in the field under Checkbox. You can use the same or 
distinct names for checkboxes. 
5 . Next to Checked Value give the two boxes the names “email” and “share.”  
6. Preview your work then save it. 
 


